Problema :
impressora não aparece no sistema dentro do acesso remoto TSPLUS mesmo estando instalada no computador cliente , onde imprime normalmente.
Possíveis causas :
1 - Impressora não é compatível com acesso remoto do Windows .
2 - Servidor não tem o driver da impressora ou mesmo a impressora no computador cliente está usando driver diferente.
Soluções:
Para a causa 1:
Verifique se a impressora é compatível com o acesso remoto do Windows RDP . Modelos como HP 127Fn e 1212NF são conhecidas por não serem compatíveis .
Nesse caso temos que colocar a impressora como padrão no computador cliente e pedir ao usuário para usar UNIVERSAL PRINTER ao imprimir dentro do sistema.
Para a causa 2 :
Verifique se o servidor tem o driver da impressora em:
CMD
Digite printui /s /t2
Verifique na janela os drivers listados sem tem da impressora :

Uma coisa que ocorre com frequência é o windows do computador cliente trocar o driver e usar um genérico.
Nessa caso tem que ir na impressora e verificar e se necessário trocar .

No caso acima a impressora alterou o driver para MICROSOFT IPP CLASS DRIVER e foi necessário voltar ele para o CANON GENERIC PLUS PCL6 que é o driver correto a ser usado.
Agora se o servidor não tiver nenhum driver da impressora , é necessário adicionar o driver ou usando o instalador normal . Muitos fabricantes disponibilizam o driver sem o instalador somente os arquivos e nesse caso é só descompactar e importar como na tela acima :

Adicione o driver no servidor e reinicie o acesso do cliente saindo e entrando novamente.